Tailwind CSS on GitHub

Browser Support

Understanding which browsers Tailwind supports and how to manage vendor prefixes.

As of v2.0, Tailwind CSS is designed for and tested on the latest stable versions of Chrome, Firefox, Edge, and Safari. Tailwind CSS v2.0 does not support any version of IE, including IE 11.

If you need to support IE 11, we recommend using Tailwind CSS v1.9, which is still an excellent and very productive framework.

Certain features such as focus-visible are included but not supported natively by all modern browsers. We’ve included information about recommended polyfills for those features directly alongside the documentation for the features themselves.

Vendor Prefixes

If you’re compiling your CSS using the tailwindcss CLI tool, vendor prefixes will be added automatically.

If not, we recommend that you use Autoprefixer.

To use it, install it via npm:

# Using npm
npm install autoprefixer

# Using Yarn
yarn add autoprefixer

Then add it to the very end of your plugin list in your PostCSS configuration:

module.exports = {
  plugins: [
    require('tailwindcss'),
    require('autoprefixer'),
  ]
}